注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

zjc的博客

技术积累

 
 
 

日志

 
 

华为NAT配置  

2009-06-12 09:55:42|  分类: 网络应用 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

配置脚本

#

sysname RouterA

#

radius scheme system

#

domain system

#

acl number 2000                    /配置允许进行NAT转换的内网地址段/

rule 0 permit source 192.168.0.0 0.0.0.255

rule 1 deny

#

interface Ethernet0/0

ip address 202.1.1.2 255.255.255.248

nat outbound 2000

#

interface Ethernet0/1          

ip address 192.168.0.1 255.255.255.0         /内网网关/

#

interface NULL0

#

ip route-static 0.0.0.0 0.0.0.0 202.1.1.1 preference 60   /配置默认路由/

#

user-interface con 0

user-interface vty 0 4

#

return

配置脚本

#

sysname RouterA

#

nat address-group 0 202.1.1.3 202.1.1.6    /用户NAT的地址池/

#

radius scheme system

#

domain system

#

acl number 2000                    /配置允许进行NAT转换的内网地址段/

rule 0 permit source 192.168.0.0 0.0.0.255

rule 1 deny

#

interface Ethernet0/0

ip address 202.1.1.2 255.255.255.248

nat outbound 2000 address-group 0    /在出接口上进行NAT转换/

#

interface Ethernet0/1

ip address 192.168.0.1 255.255.255.0         /内网网关/

#

interface NULL0

#

ip route-static 0.0.0.0 0.0.0.0 202.1.1.1 preference 60   /配置默认路由/

#

user-interface con 0

user-interface vty 0 4

#

return

5.2.4 对外提供ftp,www等服务

以www服务为例,除了5.2.1和5.2.2的配置,公网接口需要增加如下配置:

[Quidway-Ethernet0/0]nat server protocol tcp global 202.1.1.2 www inside 192.168.0.2 www

注意:如果需要其他用户可以ping通内部对外提供服务的服务器,必须增加如下配置:

[Router-Ethernet1]nat server protocol icmp global 202.1.1.2 inside 192.168.0.2

注意:内部用户不能使用公网地址来访问内部服务器,必须使用内网地址访问.

如上例子:192.168.0.0/24网段的用户,不能访问http://202.1.1.2,而只能访问http://192.168.0.2

配置脚本

#

sysname RouterA

#

radius scheme system

#

domain system

#

acl number 2000                    /配置允许进行NAT转换的内网地址段/

rule 0 permit source 192.168.0.0 0.0.0.255

rule 1 deny

#

interface Ethernet0/0

ip address 192.168.0.1 255.255.255.0              /内网网关/

nat outbound 2000

#

interface Serial0/0          

ip address 202.1.1.2 255.255.255.252              /公网出口/

nat outbound 2000                           /在出接口上进行NAT转换/

#

interface Serial0/1          

ip address 61.1.1.2 255.255.255.252              /公网出口/

nat outbound 2000

#

interface NULL0

#

ip route-static 0.0.0.0 0.0.0.0 202.1.1.1 preference 60   /配置默认路由/

ip route-static 0.0.0.0 0.0.0.0 61.1.1.1 preference 60    /配置默认路由/

#

user-interface con 0

user-interface vty 0 4

#

return

【验证】

disp ip rout

Routing Table: public net

Destination/Mask   Protocol Pre  Cost        Nexthop         Interface

0.0.0.0/0          STATIC   60   0           61.1.1.1        Serial0/1

                                             202.1.1.1       Serial0/0

61.1.1.0/30        DIRECT   0    0           61.1.1.6        Serial0/1

61.1.1.2/32        DIRECT   0    0           61.1.1.5        Serial0/1

61.1.1.1/32        DIRECT   0    0           127.0.0.1       InLoopBack0

127.0.0.0/8        DIRECT   0    0           127.0.0.1       InLoopBack0

127.0.0.1/32       DIRECT   0    0           127.0.0.1       InLoopBack0

192.168.0.0/24     DIRECT   0    0           192.168.0.1     Ethernet0/0

192.168.0.1/32     DIRECT   0    0           127.0.0.1       InLoopBack0

202.1.1.0/30       DIRECT   0    0           202.1.1.6       Serial2/0/0

202.1.1.2/32       DIRECT   0    0           202.1.1.5       Serial2/0/0

202.1.1.1/32       DIRECT   0    0           127.0.0.1       InLoopBack0

disp nat session

There are currently 2 NAT sessions:

Protocol      GlobalAddr  Port      InsideAddr  Port        DestAddr  Port

       6       202.1.1.2 12288     192.168.0.2  1036       200.1.1.1    23

VPN:  0,        status:    11,        TTL: 24:00:00,       Left: 23:59:55

       6        61.1.1.2 12289     192.168.0.3  1035       200.1.1.1    23

VPN:  0,        status:    11,        TTL: 00:01:00,       Left: 00:00:21

【提示】

1、  通过在路由上配置两条等值路由来实现负载分担

2、  如果只想实现NAT的主备用,只需要修改两条默认路由为不同的优先级即可

摘自:http://zhidao.baidu.com/question/54817258.html

  评论这张
 
阅读(9996)| 评论(4)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018